Problema 5 – Avanza 2 calles

Bueno empiezo poniendo la solucion al problema mas facil de todos, Avanza 2 calles el problema dice que karel tiene que avanzar 2 calles simple como eso tienes que hacer un programa que avanze 2 calles

Aqui explicare desde 0. Primero descarga karel, puedes encontrar el instalador en http://www.gira-izquierda.com ya que lo instalas lo abres lo primero que vez es el mundo aqui es donde esta karel…

Puedes ver una flecha azul (Karel) y unas filas(calles) y columnas(avenidas), puedes mover a karel dandole click derecho en algun lugar del mundo y posicionandolo, tambien puedes agregar paredes bueno pon a karel en la posicion 1,1 (las posiciones estan a la izquierda y abajo del mundo) orientado al norte.

luego ve a la pestaña de programa arriba y haz click en nuevo..

vas a ver esto:

________

iniciar-programa
inicia-ejecucion
apagate;
termina-ejecucion
finalizar-programa

________

Esa es la sintaxis inicial de karel

La explico:

iniciar-programa  – esto le indica a karel que hay que iniciar el programa

inicia-ejecucion – esto le indica a karel que empieze a hacer instrucciones

apagate; – Apaga a Karel (no puede hacer mas acciones)

termina-ejecucion – esto le indica a karel que ya no va a haber mas instrucciones

finalizar-programa      – finaliza el programa

Bien espero que con esta breve explicacion hayan entendido estos comandos….

Ahora queremos que karel avanze 2 calles no? como lo haces? muy bien puedes decirle a karel que avanze con la instruccion:

avanza;

entonces queremos que avanze 2 veces?

avanza;

avanza;

(nota que cada instruccion lleva punto y coma al final exepto las de ejecucion y programa)

tan simple como eso… ahora como queda nuestro codigo final:

iniciar-programa
inicia-ejecucion
avanza;
avanza;
apagate;
termina-ejecucion
finalizar-programa

Ahi lo tienes avanzas 2 calles…

como comprobar que funciona? haz click en compilar y deberia decir “Programa Compilado” si dice otra cosa es que algo hiciste mal (te falta un ; o algo asi)

ya que lo compilaste y te salio programa compilado haz click en la pestaña de ejecutar luego haz click en inicializar y corre, notaras como karel avanza las 2 calles como queriamos (si quieres que vaya mas rapido o mas lento cambia tiempo de ejecucion)

Bueno ahora para que te lo evalue en la pagina haz click en guardar y guardalo con el nombre que quieras para este ejemplo lo guardaremos como avanza-2-calles.txt

entras a http://www.gira-izquierda.com. te contectas ( si no estas registrado te registras y luego te conectas)y haces lo que te dice en esta imagen

Enviar Problema

Enviar Problema

ahora lo envias y te regresara el resultado del problema ! suerte programando

Una respuesta to “Problema 5 – Avanza 2 calles”

  1. como se pone a karel en el centro???

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

A %d blogueros les gusta esto: